Back to overview
Downtime

UK Address Based Age Verification problem

May 7, 2026 at 3:23pm UTC
Affected services
UK Address Based Age Verification

Resolved
May 7, 2026 at 4:00pm UTC

Problem solved.

Updated
May 7, 2026 at 3:26pm UTC

We are currently experiencing temporary technical issues that may cause instability in some of our services.

Created
May 7, 2026 at 3:23pm UTC

Some customers have experienced issues.